having trouble with live


For the past few days, I've been having trouble with live. It either buffers or there's a black screen that I can't click on. Please advise.
Me too. I can't seem to get workouts to load anymore. It looks like it's going to play and then it goes back to the workouts detail screen. I also had the last workout I did skip etc. I was doing the 80's step workout and was only able to get 15 minutes in and then it just stopped. The site hasn't worked since. And before you say to check my internet, it's fine. I was able to load Kelly's RAW workout fine and we are on it all the time.

I thought it was only me. Oftentimes in Live when I press 'play' the screen hangs then goes back to the description screen. After another try or two the workout loads, but there've been two times when I couldn't get any Live workouts to play at all.

I use Roku via my TV. I thought it was an internet issue on my end, but I've never had the same issue or a lag in streaming other content.
I've been having similar problems on Roku loading - press play and it then goes back to the description screen. I've also noticed the video jumping a second or two once it finally plays....
I've been having similar problems on Roku loading - press play and it then goes back to the description screen. I've also noticed the video jumping a second or two once it finally plays....
Hi dmerz, On some Roku devices, like the Roku Express, you will have to press play 3 or 4 times in order to play the video. Cathe Live is currently on the IBM platform and they recently dropped support for Roku and we assume this problem is related to IBM no longer supporting Roku, but it could also be related to something on the Roku server side of things. Roku is currently not allowing anyone to update their apps until after Jan 5th as they are making changes to their "OS". Regardless, in a couple of weeks, we hope to be ready to move Cathe Live to the Akamai platform ( same platform as Cathe OnDemand) and this should eliminate this issue and also allow Chromecast for Cathe Live.
I’m having no luck watching a live video. It keeps restarting. Tried Jingle all the way & all in upper body. I do not have Roku.
Last edited:
Today I tried PHA2020 and it kept returning to the beginning of the workout. I would restart where I guessed it had stopped but finally gave up the third time. Very frustrating.

Hi garance, I'm not sure if it was you who reported this issue to our customer service, but the solution was to reboot your router.
I don't think the router is the problem, because I have no trouble streaming other sites. I also don't feel like tackling a tech problem in the middle of what is supposed to be a time efficient workout. I didn't contact customer service, so it must have been someone else.
I'm having the same problem. Video plays for a few seconds and then restarts. Over and over. Other sites stream fine. I gave up and did a DVD.
I hear your frustration garance!
I am using Chromecast. Today I was forced to do a dvd. I did three minutes of Total Body HiiT Live, and then it froze. NOTHING I did would get it off my screen! I ended up shutting off the tv, turning it back on, and popping in a dvd.
Hi everyone,

We're not able to duplicate this error, but we have had 4 people report this issue. The first person who reported this problem solved their issue by rebooting their router. @garance, make sure to try rebooting your router. A problem like this could affect only one site while others would be unaffected. I'm not saying that this will solve your issue, but since it worked for the first person who tried this it's certainly worth trying.

Also, it would be helpful if those of you that are having an issue could answer the following questions:

  1. Are you using a PC, Mac or mobile device?
  2. Are you using our app or browser?
  3. If you are using a browser which browser are you using and is it the latest version?
  4. If you're using a PC which version of Windows are you using?
  5. If your using a MAC which OS are you using?
  6. Are you using wireless or a wired connection?
  7. What is the name of your ISP?

If some of you could answer these questions it would be helpful to us in investigating this issue since we are not able to dupolicate the problem.
Hi dmerz, with some Roku devices for Cathe Live you need to press play 3 to 5 times for it to actually play (I'm assuming this is your issue? Let me me know if you have a different problem?) We believe this an IBM issue. Unfortunately, IBM stopped supporting Roku without notice just recently and hence they will not help us with this problem. We've seen this issue on our Roku express too, so we're aware of this problem. We will be switching from IBM to Akamai pretty soon and this should solve this issue.
Yes- Pressing play several times and it will load. Hoping the switch solves the problem Thanks!
I use my MacBook Pro, OS High Sierra 10.13.6, Safari browser, and a wired connection. My ISP is Time Warner Spectrum.

Our Newsletter

Get awesome content delivered straight to your inbox.